Troubleshooting Common Issues
Xchange.Connector.CLI is not working with my connector
Symptoms
Similar error messages when executing the xchange
commands:
Could not execute because the specified command or file was not found.
The current command could not be fully resolved...
settings.json file could not be found at path...
An error occurred while initializing...
Common Causes
- The .NET tool is not installed globally
- You were working with a pre-release version of the .NET tool
- A new version of the .NET tool is available
dotnet tool
are not included in yourPATH
- Your current working directory is not the
Connector
project of your repository
Solution: Install .NET tool globally
Verify global .NET tool installation:
dotnet tool list --global
To install the .NET tool globally:
dotnet tool install Trimble.Xchange.Connector.CLI --global
Solution: Outdated pre-release or stable version
Upgrade your .NET installation to latest stable version:
dotnet tool update Trimble.Xchange.Connector.CLI --global
If your connector requires a specific version:
dotnet tool uninstall Trimble.Xchange.Connector.CLI
dotnet tool install Trimble.Xchange.Connector.CLI \
--global --version <target version>
If you need a version still in development, either out of necessity or to provide feedback:
dotnet tool uninstall Trimble.Xchange.Connector.CLI
dotnet tool install Trimble.Xchange.Connector.CLI \
--global --prerelease --version <target prerelease version>
Additional references for .NET tool usage issues:
Key violations or duplicate records when testing or developing locally
Symptoms
- When running a cache writer a key violation error message is output
- When running a cache writer you encounter duplicate records returned
Common Causes
- Change detection in your local environment is in a bad state because of a data object key was modified
- The change detection database in your local environment has become corrupted
Solution: Clean change detection for your local environment
- Build the project.
- Run
xchange test init
to set up the environment and generatetest-settings.json
. - Reset the environment with
xchange test reset
. - If issues persist, delete
bin
andobj
directories, then repeat the initialization steps.
Whenever modifying data objects, rerun xchange test init
to update test-settings.json
. If altering existing data objects, execute xchange test reset
first to avoid discrepancies in the change detection database.
Additional references for local testing:
Changes have not deployed to production environment
Symptoms
- Expected changes are not applied in Xchange production environment
Common Causes
- Connector submission was not approved by Xchange team
- Changes have not yet been released by the Xchange team
Solutions
- Verify your submission status with
xchange code list
- Email xchange_build@trimble.com and verify a release schedule for your changes